[bug fix] Gtrans does'nt work with PHP 5.4 in WordPress

Popular automatic website translation tool

[bug fix] Gtrans does'nt work with PHP 5.4 in WordPress

Postby gldb » Wed Sep 05, 2012 12:50 pm

After having loaded PHP 5.4.3, gtranslate run into error causing my website to breakdown with the following error message:
"Fatal error: Call-time pass-by-reference has been removed in C:\wamp\www\site_AAC\wp-content\plugins\gtranslate\gtranslate.php on line 46"

I am using Gtranslate 1.0.36 and WordPress 3.4.1, PHP 5.4.3

The problem is easy to fix: Edit the gtrans.php file and change the lines
GTranslate::load_defaults(& $data);
to
GTranslate::load_defaults($data);

Hope this post will help
gldb
 
Posts: 1
Joined: Wed Sep 05, 2012 12:37 pm

Re: Gtrans does'nt work with PHP 5.4

Postby Edvard » Tue Sep 11, 2012 2:44 am

Thanks for the note!
Regards,

Edvard Ananyan - GTranslate Team

Please post a review at the Joomla Extensions Directory. It is very important for us!
Edvard
Site Admin
 
Posts: 3375
Joined: Mon Jun 28, 2010 1:54 pm
Location: Yerevan, Armenia

Re: [bug fix] Gtrans does'nt work with PHP 5.4 in WordPress

Postby atlandtic » Sun Nov 25, 2012 3:44 am

Thanks very much : it works ! :D
atlandtic
 
Posts: 1
Joined: Sat Nov 24, 2012 11:40 pm


  • Related Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests

2GLux